문제
두 정수 A와 B를 입력받은 다음, A+B를 출력하는 프로그램을 작성하시오.
입력
첫째 줄에 A와 B가 주어진다. (0 < A, B < 10)
출력
첫째 줄에 A+B를 출력한다.
예제 입력
1 2
예제 출력
3
코드
import java.util.*;
public class Main {
public static void main(String[] args) {
int a, b;
Scanner sc = new Scanner(System.in);
a = sc.nextInt();
b = sc.nextInt();
System.out.printf("%d", a + b);
sc.close();
}
}
풀이는 간단하다.
알게 된 점
println
- 문자열과 숫자를 처리할 경우 문자열이 나온 이후는 전부 문자열 덧셈(덧붙이기) 처리됨
``System.out.println(2 + 1 + "d" + 3 + 4);`` → 3d34 - 중간에 계산 값을 넣어주려면 괄호로 묶어주면 된다.
``System.out.println("결과는 " + (1 + 2) + "입니다.");`` → 결과는 3입니다.
Scanner
- ``Scanner``로 입력값을 받는 경우 가변 인자처럼 처리된다.
nextInt()함수만 그런 건지 모르겠는데 입력값이 안 들어오면 프로그램이 안 끝난다(대기함)
// 테스트 코드 // 입력값의 개수에 따라 결과가 어떻게 달라지는지 확인하면 된다. import java.util.*; public class Main { public static void main(String[] args) { Scanner sc = new Scanner(System.in); System.out.println("결과는" + (sc.nextInt() + sc.nextInt()) + "입니다"); sc.nextInt(); sc.nextInt(); sc.nextInt(); sc.nextInt(); System.out.println("끝"); sc.nextInt(); System.out.println("진짜끝"); sc.close(); } }
'기타 > 백준' 카테고리의 다른 글
[백준][Java, 2588] 곱셈 (1) | 2021.09.17 |
---|